Adobe After Effects Tutorial

G ETTI NG S T A RT ED
Adobe After Effects CC is a video effects software that can be used to create animated graphics
and video special effects. Whether you plan to green screen video or add special effects, After Effects
offers all the tools needed to produce professional videos for even a beginner. This tutorial will take
you through some of the basic uses of After Effects CC
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1 . G ETT I NG S TA RT ED
Begin by opening Adobe After Effects CC 2017.
On a PC, click Start > All Programs > Adobe > Adobe After Effects CC, or click
on the After Effects short cut on the desktop. (Figure 1)
On a Mac, click Applications > Adobe After Effects CC, or click the
After Effects icon in the Dock. (Figure 2)

Figure 2

Figure 1

2. S E TTI NG U P T HE C O M P O S I T I O N
Setting up your composition correctly from the start will make your job much easier as you work
through your project. This will require some advanced planning. For example, you need to know what
you want your composition size to be and how long you want it. See Figure 3 for an example of setting
up a new composition on a Mac.

Figure 3
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2. SETTI NG UP THE C O M P O S I T I O N C O NT .
1. To create a new composition, click Composition > New Composition. This will open the
Composition Settings dialog box. Here you will be able to set the duration and size of your
composition. Options include, but are not limited to:
Composition Name: This is the name your project will be saved as.
Preset: This is the format that you will export your project as. When choosing the format of
your video, it is important to think about how you will be presenting your final piece.
Width and Height: Setting the width and height will set the dimensions of your project, the
amount of working space that you will have to work with. Checking the box that reads: “Lock
aspect ratio to 16:9 (1.78), helps you to set your composition so that it will be in high definition
(HD).
Duration: This will be the length that you want your composition to be.
Background Color: This is the color of the background of your working space.
2. When you have entered all of your composition settings, click OK.
NOTE: If you enter incorrect information in the Composition Settings dialog box, or if you need
to adjust any of this information while you are working, you can make changes any time by clicking
on the Composition Window. Then go to Compostion > Composition Settings.

3 . WORK S P A C E
The Work Space is the area in which you will create your project. When you first set up your
composition, most areas of your workspace will be blank. When you have started your project, here is
where you will find a preview of your project, the files that you have imported, your timeline and the
Effects & Presets panel. See Figure 4 for an example of a new Work Space.

Figure 4
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4 . W O RK SP A C E DES C RI P TI O N
Exploring the Work Space. There are many sections within your Work Space that you want to make
sure that you get familiar with. Figure 5 tells you about some of the more important ones:

Exploring the Work Space:
A. Composition Window
B. Toolbar
C. Files Panel
D. Timeline
E. Effects & Presets Panel
F. Preview Panel
Figure 5

Composition Window: This is the area where you will be able to see the project that you are
working on.
Toolbar: This houses all of the tools that you will use to create your project. (More information will
be in the next section, Toolbar)
Files Panel: The Files panel is where you will be able to see all of the files that you have imported into
After Effects for this project.
Timeline: This is the area in your Work Space where you will do a majority of your work. In the
timeline you will key frame your sections, add Effects & Presets and work with your layers.
Effects & Presets Panel: This panel holds all of the default effects and presets that you can add to
your project. Once you become more familiar with the After Effects program, you can add more
to this panel.
Preview Panel: When you are still working on your project and would like to preview what you have
so far or a certain section of your project, the preview panel will help you with this. Keep 		
in mind that when previewing something using the Preview Panel that it will not play back in real 		
time, it will lag.
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5 . TO O L B A R
When working in After Effects, you will utilize the toolbar often. (Figure 6) Some tools in the toolbox
have additional tools linked to them. These tools have small gray triangles in the right-hand corner. To
view the additional tools click and hold down on any tool that has a gray triangle in the corner.

Figure 6

6 . TO O LBO X DES C RI P T I O N
Selection tool
The most commonly used tool, which selects text and graphic frames and allows you to work
with an object using its bounding box.
Hand tool
Allows you to grab an object in the Composition Window so that you can move it around the frame.
Zoom tool
Allows you to zoom in on your project within the Composition Window.
Rotation tool
Takes the selected object and rotates it.
Unified Camera tool
Allows you to set up the position of your camera.
Pan Behind (Anchor Point) tool
Moves the anchor point of the object that is selected.
Rectangle tool
Creates a rectangle-shaped object. More shapes can be found by clicking on the small gray triangle in the
corner.
Pen tool
Use this tool to draw a path for text or to generate a stroke.
Horizontal Type tool
By selecting this tool you will be able to add text to your composition.
Brush tool
Use this tool to paint or brush a path as a design element.
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6 . TO O L DE S C RI P T I O N C O NT .
Clone Stamp tool
A tool that can be used to duplicate an item within the layer without creating a new layer.
Eraser tool
Select this tool to erase a part of your Composition or of a certain layer.
Roto Brush tool
Allows you to define the foreground and background of your layer.
Puppet Pin tool
Add pins to a layer to stretch and animate your layer.

7. IMPO RTI NG FI LES I NTO A F T ER EF F EC T S
1. To import files into After Effects, click File > Import > File (or Multiple Files, if you want to
import more than one at a time). This will open the Import File dialog box. Here you will be able to
select the file(s) that you would like to bring into your project.
Common File Types:
		
PSD- Adobe Photoshop document
		
AI- Adobe Illustrator file
		
JPG- Image/Photo file
		
MOV- Movie file
		
MP3- Music/audio track
		
MP4- Movie file

8 . K EY F RA M I NG
1. When working in your timeline, you will be creating layers. When you select a layer you will get
multiple options based on the layer or effect that you have chosen. To get all of the details about an
option click the triangle next to the name. Figure 7 will show you the options that you get in the timeline
section.

Figure 7
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8 . KEYFRA M I NG C O NT .
2. Next to each option under the Transform section there is a Stopwatch icon
This is the
icon that you will click to place keyframes in your timeline. When you click the Stopwatch icon, you will
see that you get diamond icons that appear on your timeline. This is how you set in and out points for an
effect. Figure 8 shows an example of the diamond icons.

Figure 8

NOTE: Once you click the Stopwatch icon to set your in point, don’t click the Stopwatch icon
again for that option because it will clear out the points that you have set in your timeline. Instead,
once you set your in point, you want to click the Diamond shape
that appears next to the
Stopwatch. Use this Diamond shape to set all other points for an option. You can see the correct Diamond shape to use in Figure 9.

Figure 9

9 . G ENERA TE A S T RO KE
1. Create a new Shape layer by going to Layer > New > Shape Layer.
2. To create a stroke, click Pen Tool (from Toolbar) and draw a line with multiple points. This will add a
new layer to your timeline section.
3. Once your line is drawn, go to Effects & Presets Panel > Generate > Stroke. Double-click
on Stroke to bring up the dialog box to view the stroke options. Figure 10 shows the Effects & Presets

Figure 10
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9 . G E NERA T E A S T RO KE C O NT.
Options include:
Color: This will be the color you want the stroke to be.
Brush Size: The thickness of the line.
Brush Hardness: How bold you want the line.
Opacity: The pertentage of transparency of the stroke.
Start: This will be the start point for the stroke.
End: This will be the end point for the stroke.
Spacing: This is how you adjust the spacing between stroke segments.

1 0 . US ING A N EF F EC T O R P RES ET
1. Create a new layer by going to Layer > New > (Choose the best layer option for the effect or
preset you wish to use).
2. Once your layer is created, go to Effects & Presets Panel > Generate > Stroke. Doubleclick on the effect or preset you wish to use to bring up the the dialog box to view the effect options.
Options vary for each effect and preset.
3. Refer back to Step 8 for keyframing your layer.

1 1 . G RE EN S C REEN A VI DEO
1. Import a video file by going to File > Import > File.
2. Once your file is imported, drag it down to the timeline and place it where you would like it in your
layers.
3. Go to Effects & Presets Panel > Keying > Keylight (1.2). Double-click on Keylight (1.2) to
bring up the the dialog box to view the options. Figure 11 shows the dialog box for Keylight (1.2).

Figure 11
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1 1 . G REEN S C REEN A VI DEO C O NT.
4. Using the bounding box that is surrounding the video in your Composition Window, make the video
as big/small as you would like it. Make sure to hold down the “Shift” key when doing so to constrain
proportions and not have your video appear morphed.
5. When you have your video placed where you would like it, go to the Keylight (1.2) dialog box and
choose the eyedropper tool next to “Screen Color”. Figure 12 shows the eyedropper tool you need to
use. Once selected, use the eyedropper tool to click on the background of your video file that you would
like to remove. Choose a color in that area that covers most of the background.

Figure 12

6. Once most of the background is gone, hover over the number next to screen gain and move the slider
left or right to remove the background.
7. When the background of your video is gone, place an image, movie, or color layer under your video
layer in the timeline. That new layer will show up behind your background layer.
NOTE: If the background of your video is not gone or does not look the way that you want it, you can
always go back and adjust the gain in the Keylight (1.2) dialog box by clicking on the video layer.

12. US ING CAMERA W I T H NU L L O B J EC T
1. Create a new Null Object layer by going to Layer > New > Null Object.
2. Make your new Null Object layer 3D by clicking on the box under Cube that corresponds with your
object icon in your timeline.You can see an example of this in Figure 13.

Figure 13

3. Create a new Camera layer by going to Layer > New > Camera Layer.
4. Make the Null Object layer a “parent” to your Camera layer. Do this by clicking the parent dropdown
on your Camera layer and choose Null 1.

Figure 14

5. Once your Null Object is parented to your Camera layer, animate the Null Object. The point of doing
this is so that the focus of the camera changes, while the camera itself does not move.
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1 3 . S AV I NG Y O U R P RO J EC T
1. Remember to save your work often. Saving frequently reduces the risk of losing the work you
have been doing. To save your After Effects project, go to File > Save as > Save As. This will bring up
the Save As dialog box that you see in Figure 15.

Figure 15

2. Make sure to save your project as an “Adobe After Effects Project”. This allows you to go back and
make changes to your project.
3. Once you have renamed your file and chose where you want to save it, click Save.

1 4 . RENDERI NG O U T VI DEO
1. Once you have completed your project, you will want to render it out. Do this by making sure your
Composition is selected in the Timeline and go to Composition > Add to Render Queue. Your
timeline will turn into the render queue like you can see in Figure 16.

Figure 16

2. In the Output Module section click the dropdown that says Lossless. In the dialog box that
comes up, you can leave all of the settings the same but you want to make sure to check the box at the
bottom that says Audio Output. Click OK.
3. In the Output To section click the dropdown that says “Comp1.mov”. In the dialog box that comes
up, choose where you would like to save your project. Make sure to leave your format as Quicktime
(*.mov), as this will be the most compatible format. Click Save.
NOTE: Your Output To might not say “Comp 1”. This will be the name that you chose when you first
set up your composition.
4. Click the Render button in the top right of the render queue.
5. Play your video using “Quicktime” to make sure that your video is working correctly.
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14. RE NDERING O U T VI DEO C O NT .
A more efficient way to save is with Adobe Media Encoder. Media Encoder can create a smaller
video file than After Effect’s default render engine, which means it is faster to load or small enough to
upload to the internet.
To render this way, go to File > Export > Export to Media Encoder
Note: It might take a few minutes for Media Encoder to load, and another additional minute for the
video to load into Media Encoder.
When you video appears in the Render Queue, click the green play button in the top right corner.
If you cannot find your finished file on the computer, click the link in the Queue next to your video’s
name, and your file will show in Finder (Mac) or Files (PC).

1 5 . CO NC L U S I O N
After reading this tutorial, you should have a basic understanding of Adobe After Effects. Please come to
the CollabLab if you have any questions about this tutorial or would like to learn more. The CollabLab is
located in room 122 of the Jerome Library.
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