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This document discusses how to get started using BGUnix, a BGSU instructional UNIX system, using
the X Windows connection provided by Hummingbird Exceed.

This document should be used by faculty, staff, and students at Bowling Green State University who
have a BGUNIX account and want to access the system with an X Windows connection.

This document contains

¢ Anintroduction to BGUnix using an X windows connection

e Instructions for logging on to and logging off of BGUnix using an X windows connection
e Description of the BGUnix frontpanel functions

e Instructions for working with directories and files in an X windows connection

e Directions for using a text editor and online help using X windows

e Additional help

The conventions used in this document are

e A = space

e ® = RETURN

e Dbold = commands

e BOLDCAPS = specific key

e 4+ = key combination

e Bold Title Case = specific names of applications, boxes, buttons, files, folders, and menus
e italics = client-supplied information

e underline typed key sequence

Additional sources include
e  Unix Systems Self-Help

http:/ /www.bgsu.edu/its/tsc/self-help/page9652.html
o “Getting Started on BGUnix”

http:/ /www.bgsu.edu/downloads/ cio/file9254.pdf


http://www.bgsu.edu/its/tsc/self-help/page9652.html
http://www.bgsu.edu/downloads/cio/file9254.pdf
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1.0 Introduction

BGUnix, a SUN E450 Server running Solaris, is the campus instructional UNIX system.
With an account, you are given login access to the system. When using a terminal
window, you will see that the default shell is a bash shell and the default prompt is a
combination of the version of bash running on the system plus a $ (dollar sign), e.g. -
bash-3.00$. BGUnix is also an X Windows enabled server that you can use to run X
applications. The system is used for general-purpose needs as well as high-demand
computation.

The system contains no email facility. For information about email at BGSU see URL:
http:/ /www.bgsu.edu/its/tsc/self-help/page9613.html

You can access BGUnix with a telnet connection or an X Windows connection. When
using an X Windows connection, you will interact with BGUnix using a Common
Desktop Environment (CDE). A CDE utilizes a Graphical User Interface (GUI),
commonly called X Windows, that is more user-friendly and intuitive than the basic
terminal emulation window provided by a telnet connection. This document provides
information on getting started on BGUnix using an X Windows connection. The
software used at BGSU for this is called Hummingbird Exceed and it is installed on the
Dell systems in Hayes 025.

Within an X Windows connection, a terminal window can also be opened to interact with
the system using all of the basic UNIX commands discussed in the “Getting Started on
BGUnix” document at

http:/ /www.bgsu.edu/downloads/cio/file9254.pdf

A BGUnix account is required to use BGUnix. For more information about the BGUnix
and software available on the system, see the Unix Systems Self Help page at

http:/ /www.bgsu.edu/its/tsc/self-help/page9652.html

2.0 Getting an X Windows Connection to BGUnix

There is a shortcut to launch Hummingbird Exceed to connect to BGUnix X Windows
under Start - Programs = Applications (see Figure 2.1)
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Figure 2.1 Start BGUnix - X windows

2.1 Logging On to the BGUNIX System

On of the first things you will see after Exceed is launched is the login screens for
BGUnix.
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Figure 2.2 BGUnix login screen

1. When prompted to enter your user name, type your BGUnix user name and
click OK or press Enter.
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Figure 2.3 BGUnix password screen

2. When prompted to enter your password, type your BGUnix password and
click OK or press Enter. For security reasons, nothing appears on the screen.

If your user name and password were entered correctly, your login process completes
and calls up your desktop.

If you enter an incorrect user name or password, an error message popup window
appears with the message “Login incorrect; please try again.” Click the OK button.
BGUnix then starts the login process again.

2.2 Logging Off of BGUnix
To log off of BGUnix:
1. Click the Exit button in the center of the front panel (toolbar) (See Figure 3.1).

2. A Logout Confirmation dialog box appears to verify your decision to log out.
Click OK to logout. See Figure 2.4.
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I Logout Confirmation I

Exiting the desktop session...
Application updates you have not saved may be lost.
£
*  Your current session will be saved and returned to
upoh your next login. For more detail, select Help.

Continue Logout?

OK Cancel Help

Figure 2.4 Logout Confirmation

3. After closing the login shell window, you also need to close the Hummingbird
Exceed session window by right clicking on the Exceed icon on your task bar
and selecting Close on the pop-up menu. (See Figure 2.5).

Note: You may also see a login session item on your task bar. Make sure you are
right clicking on the Exceed icon, not the login session icon.

iy 513rt| |g Exceed Trrtitled - Paint

Figure 2.5 Logging Off of BGUnix

4. Click OK in the confirmation popup window to end your X Windows session.

3.0 Using the Graphical User Interface (GUI)

The Graphical User Interface (GUI) on BGUnix operates in the same way that most GUIs
work on a personal computer in that you can click and drag objects, double click to open
objects, and throw objects into the trash. When using the GUI, use the left mouse button
to perform most operations. To see a menu associated with an item before selecting it,
click on the icon once with the right mouse button.

For almost every task you perform using the interface, there are multiple ways to
accomplish it. Consult the online help for alternatives. The help viewer will
automatically be open the first time you login to BGUNIX.

3.1 Using the Front Panel
All BGUnix’s workspaces contain a front panel that contains icons for the functions used

most often. See Figure 3.1. You can click on each icon and also drop files or folders on
some icons to perform specific tasks.
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The front panel originally located at the bottom of the screen (see Figure 3.1 below) is
divided into three branches. The icons contained in the left branch, center section, and
right branch are explained below. To move the front panel to a different location on your
desktop, grab it on either end using the move handles that look like a grey and black
textured surface.
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3.1.1 Using the Left Branch of the Front Panel

The left branch of the front panel is made up of five icons. The icons and their functions
are listed below, from left to right.

Clock - displays the current time and when clicked, opens your web browser

Calendar - when clicked, opens an application to keep track of your personal schedule
File Manager - when clicked, opens your home folder or you can drop a folder on it to
open that folder

Text Note - when clicked, starts an editor so you can create a text file

Mailer - no email is delivered to BGUnix so this feature is not supported

Lock - appears to lock your display so it cannot be used by someone else but this can be
overridden if a lab system is left in this state too long.

3.1.2 Using the Right Branch of the Front Panel

Like the left branch, the right branch of the front panel is made up of five icons. The icons
and their functions are listed below, from left to right.

Personal Printer -Since BGUnix does not use the default print system, this feature is not
enabled. For printing, use terminal emulator window and issue print commands from
the command line. See Section 6.0, Printing from BGUnix.

Style Manager - opens the Style Manager so you can customize your workspaces
Performance Meter - opens a windows that displays the performance meter

Help - accesses the online help (see Section 10.0, Using the Online Help)

Trash - when clicked, opens the trash can window; when a file or folder is dropped, it
moves it to the trash
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3.1.3 Using the Center Section of the Front Panel

The center section of the front panel contains your workspaces. Four different
workspaces can be with defined with different options. One can switch between them
while logged in to BGUnix by clicking the button of the workspace desired. Switching
between workspaces is helpful when using multiple applications.

The center section also includes the EXIT button, which can be used to log off. For more
information about logging off, see Section 2.2, Logging Off of BGUnix.

3.2 Using the Subpanels

You can click on the small up arrow I “"| above each icon on the front panel to

select functions from its subpanel. For example, if you click on the arrow above the
Performance Meter icon, you will see the Hosts subpanel. See Figure 3.2. You can select
“This Host” from the Hosts subpanel when you need access to BGUnix from the
command line in a terminal emulator window.
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Figure 3.2 Hosts Subpanel
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For more details about the Front Panel and functions available in the Subpanels, select
Front Panel Help from the Help Subpanel by clicking on the arrow above the Help
Manager. You can also right click on every icon on the front panel and select Help from
the menu displayed to get more details about that function and its menus.

3.3 Using the Window Control Icons

There are a set of window control icons and you may see various combinations of these
in the windows available to you while using BGUnix.

Clicking on this icon gives you access to a menu of window controls. On the menu,
you can see a key combination that performs the same menu option on the active
window. This window control usually appears in the left corner of the window.

Clicking on this icon minimizes the window. Click on the minimized item to see it’s
menu and select restore to re-open that window.
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Clicking on this icon maximizes that window so it fills up the entire screen. Click on
the icon again to return the window to its normal size.

4.0 Working with Directories and Files

BGUnix has a file manager that can be used to access and maneuver among directories

and files. The file manager performs duties similar to those performed by the file
manager used in Microsoft Windows.

4.1 Using the File Manager

To open the file manager, click on the file manager icon in the center of the left branch of
the front panel (see Section 3.1.1, Using the Left Branch of the Front Panel). When you

click on the icon, the file manager on BGUnix displays your home directory. (See Figure
4.1, File Manager Window).
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Figure 4.1 File Manager Window
4.1.1 Opening a Directory or File

To open a directory or file, double click on the icon. Directories are represented as folder
icons and, when opened, display the directories and files existing within. Files are
represented by page icons and, when opened, display the contents in a text editor.

4.1.2 Moving Up in the Directory Structure

To move up one directory, double click on the folder labeled ..(go up). To return to your
home directory, select the File menu and highlight Go Home or in the group of folders
right below the menu names, click on the folder that is labeled with your account name.

4.1.3 Creating a New Directory
To create a new directory, follow these instructions:

1. Open the directory where you want the new directory to reside.
2. Select the File menu and highlight New Folder.
3. The File Manager — New Folder dialog box opens (see Figure 4.2, New Folder

Dialog Box, below). In the New Folder Name box, type the name to give to the
new directory.
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4. Click OK.

New Folder Name:l ‘ _—-,
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Figure 4.2 New Folder Dialog Box

4.1.4 Deleting a Directory or File
To delete a directory or file, follow these instructions:

1. Click once on the item to delete to select it. It will be highlighted.
2. Go to the Selected menu and choose Put in Trash.
Or you could just press DELETE on the keyboard.

Upon deleting a file or empty directory, the item is placed in the trash automatically,
where it remains until the trash items are shredded. If deleting a directory that contains
files or other directories; however, a Trash Can Warning dialog box appears. If the
directory and all its contents truly are to be deleted, click OK.

4.1.5 Open several views of File Manager

Sometime, it’s desired to open two or more views of file manager to make some tasks
easier to do (like move or copy files/directories). To do so, follow these instructions:

1. Click once on the directory you want to open in a new view to select it. It will
then be highlighted.
2. Right click and select Open New View

4.1.6 Copying/Moving a Directory or File

To copy a directory or file from one location to another, follow these directions:
1. Open the folder that contains the source files/directories to copy/move
2. Open a new view of destination folder (see 4.1.5 for instructions)
3. In the source file folder, select all the files and directories to copy/move
4. If copying files or directories, hold down the Control Key; if moving files or
directories, skip this step.
5. Drag source files/directories to the destination folder

5.0 Using the Text Editor

BGUnix has a text editor that can be used to create new files and edit existing ones.

5.1 Creating New Files
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To create a new text file, click Text Note icon in the left branch of the front panel (see
Section 3.1.1, Using the Left Branch of the Front Panel). The editor is a menu-guided
system, similar to most word processing programs. The File menu allows one to create a
new file, open an existing file, save a file, print a file, or close a file. The Edit menu
allows one to undo the last command performed; cut, copy, and paste text; find and
change text; and spell check the document. The Format menu allows one to change the
format of the text, including the justification and line width. The Options menu gives
access to other options, such as overstrike, word wrap, and status line.

5.2 Editing Existing Files
Upon double clicking on a file within the file manager, the file opens in the default text

editor. One can also open a file through an already started text editor session through
the Open option on the File menu.

6.0 Printing from BGUnix

To print files from X-windows environment, you must open a terminal window and
issue print commands from the command line. The personal printer icon on the front
panel is designed for a different print system than the one used on BGUnix so it is not
supported. Also for the same reason, the Print option on any menu does not work.

For instructions on getting a terminal window from within an X windows connection,
see Section 8.0, Accessing the Terminal Window.

Your file must be in text format. If you know the printer name, use this form of the print
command:

Ipr -P printername filename
The filename is the name of the file you need to print. The printer name or alias for the
Hayes 025 Lab is hayes025. To see the printer names of other printers in other locations
on campus, look at the contents of /usr/local/etc/printcap.

more /ust/local/etc/printcap

If you are working in a campus office and know the IP address of a printer on the
network, you can use this form of the print command:

Ipr -h -P@IPaddress filename

You can get the IP address of the printer by printing out the printer’s configuration file.

7.0 Emptying the Trash

10
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When items are deleted, they automatically go to the trash. The trash must be emptied to
delete the files from the system permanently. BGUnix requires that one shred any files
not to be kept. To shred trash, follow these instructions:

Double click on the trash can icon in the last section of the front panel.
Select the File menu and highlight Select All.

Select the File menu and highlight Shred.

The Shred File(s) dialog box appears. Click OK to shred the trash.

Ll

8.0 Accessing the Terminal Window

All of the command line operations that are available on BGUnix can still be performed
while using an X connection by opening a terminal window. There are two ways to open
a terminal window:
e  Click on the arrow above the Performance Meter icon to display the Hosts
Subpanel and select “This Host’” from the menu.
e Click on the File Manager icon to open it and select Open Terminal from the

File menu.
Window Edit Options Help
i | -

Figure 8.1 Terminal Emulator Window

You will already be logged into your account and see a command line prompt. From a
terminal window, BGUnix works just like it does when you use a telnet session to access
the system. For more information about commands issued from the line command,
consult the “Getting Started on BGUnix” at URL:

http:/ /www.bgsu.edu/downloads/cio/file9254.pdf
9.0 Resetting your X Windows Environment

When you are using an X Windows environment, the system keeps track of what
windows you have opened and closed in each workspace and when you log in, it re-

11
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opens the same set of windows you were using when you last logged out. If you are
having problems with your X Windows environment or just want to reset it back to the
way it originally was set up, you can do that in a telnet session. Access BGUnix using a
telnet connection (e.g Select Run on the PC Start menu and at the open prompt enter
telnet.bgsu.edu). From your HOME directory, the following two commands will reset
your X environment:

‘-,J! Telnet bgunbcbgsuw.edu

Sun05 5.8

login:
Password:
Last login:

¢ susr/binsrm —rf .dt
S cp —» Afetcrskel/dE .

Figure 9.1 Resetting X Windows Environment

$ /usr/bin/rmA-rfA.dt* (removes the contents of your .dt directory)
$ cpA-rifetc/skel/.dtA. (replaces your .dt directory with default setup files)

Make sure to enter the commands exactly as they appear here with one space
(represented by A in the example above) between each argument.

Note: The last cp command has 3 arguments (a -1, a directory name and a period). The
period stands for the current directory.

10.0 Using the Online Help

BGUnix has an extensive online help system. To access this help, click the help manager
icon in the right branch of the front panel. The help begins with a viewer (see Figure
10.1) that allows the choice between two general topics: Common Desktop Environment
(CDE) or Overview and Basic Desktop Skills.

The upper window in the help viewer shows the basic topics that are available in any
given section; click on any of these topics to go to more information about that topic. The
lower window contains the text and various hyperlinks that can be followed to access
more information. The hyperlinks are underlined words that transfer to other sections of
the current volume or another volume. Sometimes a hyperlink opens a new help
window, other times it uses the current one. If the hyperlink is a dotted underline, it
opens a pop-up definition window.

The Backtrack button, which is located on the right side of the upper window, allows
one to move back one hyperlink. The History button calls up a list of the places you
visited and allows you to click and revisit pages. The Index button gives you a list of all
of the information available and also allows you to search for the information wanted.
The Top Level button takes you back to the help viewer.

12
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:
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Owverviews and Basic Desktap Skills for the Camman Desktop
Environment.

]

Figure 10.1 Help Viewer

11.0 Additional Help

For questions or problems associated with BGSU hardware, software, network
connections, BGNet accounts, and class accounts, clients can consult the TSC
Self-Help web pages at URL:

http:/ /www.bgsu.edu/its/tsc/self-help/
or stop in at the Technology Support Center (TSC) in Hayes Hall, room 129. TSC
consultants can be reached by phone at 419-372-0999 or by using the TSC Online
Submission form at URL:

http:/ /www.bgsu.edu/its/tsc/page9500.html

If you have any comments, corrections, or suggestions concerning this document, contact
the Technology Support Center at tsc@bgnet.bgsu.edu.

Photocopying of this document is encouraged. Reprints of this document’s content are
permitted if credit is given and a copy is sent to ITS Documentation, 265 Hayes Hall.
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